[email protected] +1.303.779.0344

Excel versions supported by OnePager Express

OnePager Express requires Microsoft Excel, and supports the following versions:

  • Microsoft Excel 2019 (32-bit or 64-bit)
  • Microsoft Excel 2016 (32-bit or 64-bit)
  • Office 365
  • Microsoft 365 Apps for Enterprise
  • Microsoft Excel 2013 (32-bit or 64-bit)
  • Microsoft Excel 2010 (32-bit or 64-bit)
  • Microsoft Excel 2007
  • Microsoft Excel 2003

    • Last Updated: March 30, 2021